Back to overview
Degraded

Some site slowness

Jan 04 at 07:36pm EST
Affected services
The Weather Station Experts (HAL2)
AltWire (HAL2)

Resolved
Jan 04 at 07:46pm EST

Process has completed.

Created
Jan 04 at 07:36pm EST

Due to a server process, websites may load slightly slower than usual. Process should be completed by 8:00pm ET.