Back to overview
Degraded

Altus Pre-Launch Instability

May 5, 2026 at 2:56am UTC

Resolved
May 13, 2026 at 4:53am UTC

Altus remains in pre-release, but should be stable and no longer crash unexpectedly.

Created
May 5, 2026 at 2:56am UTC

Altus may go up and down throughout the next 24-48 hours as it is prepared for launch. Another status update will be posted when the service is fully stable.