Railway Platform Outage — MCP Servers Affected, No Customer Service Impact
Resolved
May 20, 2026 at 8:06am UTC
Railway is saying that the issue should be fully resolved.
Affected services
Updated
May 20, 2026 at 5:12am UTC
While services have returned online, and database connectivity has returned, Railway as of 1:30 am ET is not listing the incident as resolved. Services returned online around 10:30 pm ET.
Affected services
Updated
May 20, 2026 at 1:51am UTC
Railway has successfully restored portions of its service; database connections remain inoperable. As a non-enterprise deployment, our deployments are being deprioritized to keep the build infrastructure stable. There is still no ETA for full recovery.
Affected services
Updated
May 20, 2026 at 1:38am UTC
Railway customer reports suggest that the service outage is primarily affecting Bare Metal-based deployments. Some MCPs were transitioned to Railway's metal infrastructure, but not all. This may explain why Hal was still able to call out during the outage, since that uses Ventus, which we believe is not on Railway's Bare Metal.
Affected services
Created
May 20, 2026 at 1:34am UTC
The Railway deployment platform is currently experiencing a significant outage. This has caused our three internal MCP servers (Nimbus, Cirrus, and Altus) to go offline, as they are hosted on Railway.
All customer-facing services remain fully operational:
• Cirrusly Weather Front Page ✅
• Cirrusly Weather Shopping Cart ✅
• Cirrusly Weather REST API ✅
• AltWire Front Page ✅
• Matomo ✅
This is not a service outage. We are monitoring the Railway incident and will restore the MCP servers as soon as Railway comes back online. No customer data or functionality is affected.
Affected services